Menu

Merchant help > Technical resources

Browser support

Revised 26 October, 2016

Pay with Amazon supports the use of the operating systems, browsers, and browser versions listed below.

Note that you and your buyers may be able to use other operating systems, browsers, and browser versions without encountering errors. However, our goal is to provide the best experience to the majority of customers, and to ensure that the browsers used include the latest security updates. Therefore, we recommend using the versions listed below.

Note: We fully support the latest versions of all of the browsers listed below; for some earlier browser versions that are not used by many customers, we offer limited support.

Desktop/laptop

The browsers supported for use with Pay with Amazon on a desktop or laptop:

  • Windows 7: Google Chrome (53 and later); Mozilla Firefox (49 and later); Internet Explorer (11 and later)
  • Windows 10: Google Chrome (52 and later); Mozilla Firefox (49 and later); Internet Explorer (15 and later)
  • Mac OS X v.10.11: Apple Safari (9.1 and later)

Mobile/tablet browser

The browsers supported for use with Pay with Amazon on a mobile device or tablet:

  • Google Chrome 54 and later on Android 6.0.1 and later
  • Google Chrome 54 and later on iOS version 9.3.5 and later
  • Safari Mobile 9 and later on iOS version 9.3.5 and later

Mobile SDK

The OS versions supported for use with the Pay with Amazon Mobile SDK:

  • iOS: iOS 8 and later
  • Android: Android 4.1 and later